Apple varuje uživatele ohledně zastaralých rozšíření systému macOS. Vaše VPN už příště nemusí fungovat

Apple společně s aktualizací systému macOS 10.15.4 posouvá bezpečnost o krok dále. Systémová rozšíření už nebudou v příštích verzích fungovat.

Pokud jste nadšeně aktualizovali macOS na poslední verzi 10.15.4 a používáte aplikace, které využívají systémová rozšíření, pak jste spatřili podobné varovné hlášení jako my.

Takto nás vítá spuštění VPN klienta Cisco AnyConnect

To upozorňuje, že v příštích verzích operačního systému macOS bude ukončena současná podpora rozšíření systému a aplikace budou muset přejít na nový framework.

Systémová rozšíření sahají přímo k jádru macOS (kernelu), aby přidaly nezbytné funkce. To s sebou samozřejmě nese riziko a Apple hodlá tuto cestu odebrat.

V hlavní roli bezpečnost a stabilita macOS

Apple vývojářům nachystal potřebný dokument, který popisuje cestu a důvody tohoto kroku. Primárně cílí na stabilitu celého operačního systému macOS a jeho bezpečnost.

Nový framework „EndpointSecurity“ bude tak jedinou cestou, jak rozšířit funkčnost systému v chystané verzi macOS 10.16 a novějších. Vývojáři by měli mít dostatečný čas, aby se na tuto změnu připravili.

Apple (anglicky)

avatar

Petr Škuta

Od roku 2009 působím jako redaktor a editor. Ve stejné době jsem rovněž začal používat svůj první MacBook a začal se specializovat na produkty Apple. V minulosti jsem se věnoval kariéře pedagoga, avšak můj zájem o IT vyrostl z koníčku v hlavní pracovní náplň. Nyní se kromě psaní věnuji také konzultacím, poradenství a hlavně školení nejen produktů značky Apple.

banner